Autocad 2014 now Supported on Windows 8

For those of you waiting for confirmation of the Windows 8 compatibility for Autocad the following is the current sysyem requirements for the latest release:

AutoCAD LT 2014 System Requirements

For 32-bit AutoCAD LT 2014

  • Windows® 8 Standard, Enterprise, or Professional edition, Windows® 7 Enterprise, Ultimate, Professional, or Home Premium edition, or Windows XP® Professional or Home edition (SP3 or later) operating system
  • For Windows 7 and Windows 8: Intel® Pentium® 4 or AMD Athlon™ dual-core processor, 3.0 GHz or higher with SSE2 technology
  • For Windows XP: Pentium 4 or Athlon dual-core processor, 1.6 GHz or higher with SSE2 technology
  • 2 GB RAM
  • 4 GB free disk space for installation
  • 1,024 x 768 VGA display with true color
  • Microsoft® Internet Explorer® 7 or later web browser
  • Install from download or DVD

For 64-bit AutoCAD LT 2014

  • Windows 8 Standard, Enterprise, or Professional edition, Windows 7 Enterprise, Ultimate, Professional, or Home Premium edition, or Windows XP Professional edition (SP2 or later)
  • AMD Athlon™ 64 with SSE2 technology, AMD Opteron™ processor with SSE2 technology, Intel® Xeon® processor with Intel EM64T support with SSE2 technology, or Pentium 4 with Intel EM64T support with SSE2 technology
  • 2 GB RAM
  • 4 GB free disk space for installation
  • 1,024 x 768 VGA display with true color
  • Internet Explorer 7.0 or later
  • Install from download or DVD
Comment are closed.